ID: 851

Working with Adobe Photoshop

Step-by-step guide to using Zoom with Adobe Photoshop

Photoshop - Creative App Panel

If you do not see an Evolphin Zoom panel under Window > Extensions > Evolphin Zoom, install the plugin manually using Installing Creative App Plugin .

Evolphin Zoom is able to handle assets that are both individual assets and entire folders. Within Photoshop, most Photoshop documents are composed of one individual PSD file. However, there are also instances where a Photoshop file may be composed of multiple assets.

In Photoshop CC, Adobe introduced the Generate Assets feature that allowed users of Photoshop to generate multiple sub-images that are automatically created when the Photoshop document is updated. When this occurs, you may want to checkin your assets next to the Photoshop document as well as the Photoshop document.

In instances such as these, it is suggested to store your Photoshop document and related assets in an individual folder.

Photoshop Folder Structure

In Zoom 5.1 and greater, Zoom can read all of the layers inside a Photoshop document automatically. This allows you to view the Layers within Zoom without even having to have Photoshop installed or open.

In order for Zoom to properly read the layers in a Photoshop document, you MUST checkin the Photoshop asset using the Creative App Plugin in Photoshop CC or greater. The reason for this is that Zoom depends on Photoshop to read the information about the asset layers. It does not matter whether the asset is a new asset or a new revision of an asset already in Zoom; as long as the graphic is checked in using Photoshop, Zoom will read the layers.

Reading Photoshop layers is not supported in Photoshop CS6.

In Photoshop CC, Adobe introduced the concept of linked assets in Photoshop. Similar to InDesign, Illustrator, and other Adobe applications, this meant that assets could be placed into Photoshop and maintain a link with the original asset. If the original asset was updated, then the Photoshop document would be updated.

Layers Panel - Asset Browser
Layers panel – Asset Browser

In Zoom 5.1 and greater, Zoom can read the linked assets inside of a Photoshop document automatically based on which layers. Assets are automatically linked in Zoom so you can see which assets derivatives there are of that original asset.

Reading Photoshop layers is not supported in Photoshop CS6.

 

Link Assets in Photoshop

In order to link assets in Photoshop, you must use the Place function in Photoshop. Drag-and-dropping into Photoshop does not place the image; it will embed the image into the Photoshop document. In order to link the asset, you must do the following:

  1. Open your Photoshop document.
  2. Go to File > Place Linked…

    Place Linked... - Adobe Photoshop
    Place Linked… – Adobe Photoshop
  3. Navigate to the asset you have checked out in your Working Copy folder.
  4. Click Place.

When you checkin your asset, the layer containing your linked asset will have an image link. You can then click the Visit Visit Parent AssetParent Asset button to navigate to that asset in Asset Browser. Your asset will also be linked in the Links panel.

Prior to Zoom 5.1, the process of checking in an asset was referred to as Commit.

There are a variety of different ways assets can be checked into Zoom. Assets can be checked into Zoom directly from within a Creative App without having to depend on Asset Browser. For additional information on how to Check-in, see Checkin Assets .

Check-in Unversioned File

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0: Click Sync.

    Zoom 6.0 or below: Click Check-in
    Checkin

  4. Choose Server URL if prompted.
    Check Browse - Checkin Dialog
    Check Browse – Check-in Dialog

  5. Click Browse to choose the location in Zoom to checkin the asset if prompted.
  6. Fill out any required metadata or keyword values.
  7. Enable Convert to working copy in order to check-in the unversioned file and start editing on it right away as a versioned file once it is checked-in
  8. Click Check-in.

Check-in Versioned File

In order to check-in existing assets into Zoom via the Creative App panel, your file must already be saved on your computer.

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0: Click Sync.
    sync checkin

    Zoom 6.0 or below: Click Check-in.
    Checkin

  4. Fill out any required metadata or keyword values.
  5. Click Check-in.

Check-in Options

Option Description
Check-in Parent Folder Checks in the folder that contains the current document.
Convert to working copy Copies the file from its current location to its location in the default working copy folder on your computer.
Keep files locked Zoom automatically unlocks assets when performing a Check-in. Enabling this will keep the asset locked after checkin.
Change thumbnail Zoom will search for a _tb file in the same directory as the asset.

 

Quick Checkin*

*Not available in Zoom 7.0+

Assets can also be checked into Zoom using the Quick Checkin button in the Creative App panel as described here:

Quick Checkin allows users to quickly checkin assets to a specified location in Zoom. This will also forego any required metadata dialogs. This is useful particularly in environments such as news organizations that need to quickly import items into Zoom and perform organization later. Quick Checkin must be configured in order to work properly.

Quick Checkin

Prerequisites:

  1. Open Settings dialog from Z-Icon in the system tray.

    Settings Dialog
    Settings Dialog
  2. Set default zoom server and make sure to select Always Use Default.

    Default Server
    Default Server
  3. Open zoom.properties file from $HOME/.zm
    For Example:  /Users/joe/.zm/zoom.properties
  4. Add default Quick Checkin destination folder.
    Syntax: QUICK_CHECKIN_DEST=/defproj
    /defproj is the path on zoom server where Quick Checkin files will go to.
  5. The Quick Checkin dialog will not appear by default. Add SHOW_QUICK_CHECKIN property in zoom.properties file, if you want to the Quick Checkin dialog to appear.
    Syntax: SHOW_QUICK_CHECKIN=TRUE
  6. If mandatory metadata is enabled on zoom server, make sure to save the default metadata template from checkin dialog
    1. Open Checkin dialog.
    2. Fill all the mandatory metadata fields.
    3. Click the save button
      Metadata Template

 

 Launch Quick Checkin:

    1. Save your current document.
    2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
      Window > Extensions > Evolphin Zoom
    3. Click Quick Checkin.
      Quick_checkin
    4. Click Checkin in the Quick Checkin dialog.
      The Quick Checkin dialog will not appear if SILENT_QUICK_CHECKIN is set to TRUE in zoom.properties file.

Within Zoom, creating copies of files is easy using Smart Copy. Unlike conventional copying of files which takes up additional data, creating a Smart Copy allows a file to be copied and edited without having to duplicate data on the server. You can create smart copies of a file or an entire folder. For additional information on Smart Copy, see Smart Copy Assets .

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0: Click Fly-out menu > Clone Project

     

    Zoom 6.0 or below: Click Smart Copy.
    SmartCopy

  4. Choose Server URL.
    Check Browse - Checkin Dialog
    Check Browse – Checkin Dialog

  5. Click Browse to choose the location in Zoom to checkin the asset.
  6. Fill out any required metadata or keyword values.
  7. Enable or disable Convert to working copy.
  8. Click Smart Copy.

Lock is a feature in Zoom that allows you to restrict who is working at a file at one time. This helps communicate to users which files have been delegated to which users at a time. When a file is locked, other users in Zoom are not able to commit a new version of the file until you have released the lock on the file.

When you Checkin an asset, the asset is automatically unlocked unless you explicitly check Keep files locked in the Checkin dialog.

Lock

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0: Toggle Lock

    Zoom 6.0 or below: Click Lock/Unlock and select Get Lock.
    LockUnlock

  4. Choose Server URL.
    Check Browse - Checkin Dialog
    Check Browse – Checkin Dialog

Release Lock

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0:


    Zoom 6.0 or below: Click
     Lock/Unlock and select Release Lock.
    LockUnlock

  4. Choose Server URL.
    Check Browse - Checkin Dialog
    Check Browse – Checkin Dialog

When editing an asset inside of Zoom, Revert allows you to revert back to the last revision checked out from the Zoom Server. This will remove any of the modifications that were applied to the asset.

Revert Changes

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  2. Zoom 7.0: Click Revert Project from the fly-out menu

     

    Zoom 6.0 or lower: Click Revert. In the drop-down, select Revert Changes.
    Revert

  3. Click OK.

When a file is changed on the Zoom Server, for example a new version is created, the file on your computer now is older than the latest version on the server and needs to be updated. Updating the files will update the file if there is a newer version or move it if it was moved on the Zoom Server.

Update Asset

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  2. Zoom 7.0: Click Sync. Sync will determine if update from or check-in to server is needed.

     

    Zoom 6.0 or lower: Click Update.
    Update

  3. Click OK.

The Task Manager allows users who have the Workflow module to accept and submit tasks assigned to them within a Workflow Job. The Task Manager can be launched directly from with the Creative App Plugin.

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.

    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom
  2. Click Task Manager.
    TaskManager
  3. Click OK.

The Show in Asset Browser button in the Creative App Plugin allows users to navigate to the asset they have open in the Creative App within Asset Browser.

Show Current Asset in Asset Browser

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  2. Zoom 7.0: Click 

    or from any view, select a file:

    Zoom 6.0 or below: Click Show in Asset Browser.
    ShowInVAB

  3. Click OK.

Incoming Changes allows you to view what working copies on your computer currently have never revisions on the Zoom Server. Accessing Incoming Changes is possible directly through the Creative App Panel.

Revert Changes

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.

    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom
  2. Click Incoming Changes.
    Incoming Changes - Creative App Panel

The Zoom Repository button in the Creative App Plugin will allow you to launch the Zoom Repository from directly within your Creative App.

Launching Zoom Repository

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.

    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom
  2. Click Zoom Repository.
    Zoom Repository icon - Creative App Panel

The Status button shows the detailed current status of a working copy on your computer locally and on the Zoom Server. This includes information such as File Status, Size, Modification Date, etc.

View Asset Status

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.

    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom
  2. Click Status.
    Status

Reveal in Explorer button in the Creative App Plugin navigates to the working copy within Windows Explorer or the Apple Finder on your computer.

Reveal in Windows Explorer or Apple Finder

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
  2. Zoom 7.0:

    or from any file that can be accessed without the cloud icon:

    Zoom 6.0 or below: Click Reveal in Explorer.
    RevealInExp