ID: 857

Working with Adobe After Effects

Step-by-step guide to working with Adobe After Effects

AE_plugin

Install Adobe Extension

If you do not see an Evolphin Zoom panel under Window > Extensions > Evolphin Zoom, install the plugin manually using Installing Creative App Plugin .

Links in After Effects

In After Effects, assets can be placed into the project. The assets that are added to compositions are checked into Zoom as linked assets.

AE_links

While checking in an asset, check on the Check-in linked assets checkbox to check in the linked files along with the AEP project.

AE_Checkin_links

The links will get checked in along-with the After Effects project. The links will appear in the Links panel in the Asset Browser.

AEP_links_VAB

The Layer panel of Assets Browser would show the layers that the compositions contain. It will show the links grouped under their individual compositions.

AE_VAB_Layers

Prior to Zoom 5.1, the process of checking in an asset was referred to as Commit.

There are a variety of different ways assets can be checked into Zoom. Assets can be checked into Zoom directly from within a Creative App without having to depend on Asset Browser. For additional information on how to Check-in, see Checkin Assets .

Check-in Unversioned File

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0: Click Sync.

    Zoom 6.0 or below: Click Check-in
    Checkin

  4. Choose Server URL if prompted.
    Check Browse - Checkin Dialog
    Check Browse – Check-in Dialog

  5. Click Browse to choose the location in Zoom to checkin the asset if prompted.
  6. Fill out any required metadata or keyword values.
  7. Enable Convert to working copy in order to check-in the unversioned file and start editing on it right away as a versioned file once it is checked-in
  8. Click Check-in.

Check-in Versioned File

In order to check-in existing assets into Zoom via the Creative App panel, your file must already be saved on your computer.

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0: Click Sync.
    sync checkin

    Zoom 6.0 or below: Click Check-in.
    Checkin

  4. Fill out any required metadata or keyword values.
  5. Click Check-in.

Check-in Options

Option Description
Check-in Parent Folder Checks in the folder that contains the current document.
Convert to working copy Copies the file from its current location to its location in the default working copy folder on your computer.
Keep files locked Zoom automatically unlocks assets when performing a Check-in. Enabling this will keep the asset locked after checkin.
Change thumbnail Zoom will search for a _tb file in the same directory as the asset.

 

Quick Checkin*

*Not available in Zoom 7.0+

Assets can also be checked into Zoom using the Quick Checkin button in the Creative App panel as described here:

Quick Checkin allows users to quickly checkin assets to a specified location in Zoom. This will also forego any required metadata dialogs. This is useful particularly in environments such as news organizations that need to quickly import items into Zoom and perform organization later. Quick Checkin must be configured in order to work properly.

Quick Checkin

Prerequisites:

  1. Open Settings dialog from Z-Icon in the system tray.

    Settings Dialog
    Settings Dialog
  2. Set default zoom server and make sure to select Always Use Default.

    Default Server
    Default Server
  3. Open zoom.properties file from $HOME/.zm
    For Example:  /Users/joe/.zm/zoom.properties
  4. Add default Quick Checkin destination folder.
    Syntax: QUICK_CHECKIN_DEST=/defproj
    /defproj is the path on zoom server where Quick Checkin files will go to.
  5. The Quick Checkin dialog will not appear by default. Add SHOW_QUICK_CHECKIN property in zoom.properties file, if you want to the Quick Checkin dialog to appear.
    Syntax: SHOW_QUICK_CHECKIN=TRUE
  6. If mandatory metadata is enabled on zoom server, make sure to save the default metadata template from checkin dialog
    1. Open Checkin dialog.
    2. Fill all the mandatory metadata fields.
    3. Click the save button
      Metadata Template

 

 Launch Quick Checkin:

    1. Save your current document.
    2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
      Window > Extensions > Evolphin Zoom
    3. Click Quick Checkin.
      Quick_checkin
    4. Click Checkin in the Quick Checkin dialog.
      The Quick Checkin dialog will not appear if SILENT_QUICK_CHECKIN is set to TRUE in zoom.properties file.

Within Zoom, creating copies of files is easy using Smart Copy. Unlike conventional copying of files which takes up additional data, creating a Smart Copy allows a file to be copied and edited without having to duplicate data on the server. You can create smart copies of a file or an entire folder. For additional information on Smart Copy, see Smart Copy Assets .

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0: Click Fly-out menu > Clone Project

     

    Zoom 6.0 or below: Click Smart Copy.
    SmartCopy

  4. Choose Server URL.
    Check Browse - Checkin Dialog
    Check Browse – Checkin Dialog

  5. Click Browse to choose the location in Zoom to checkin the asset.
  6. Fill out any required metadata or keyword values.
  7. Enable or disable Convert to working copy.
  8. Click Smart Copy.

Lock is a feature in Zoom that allows you to restrict who is working at a file at one time. This helps communicate to users which files have been delegated to which users at a time. When a file is locked, other users in Zoom are not able to commit a new version of the file until you have released the lock on the file.

When you Checkin an asset, the asset is automatically unlocked unless you explicitly check Keep files locked in the Checkin dialog.

Lock

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0: Toggle Lock

    Zoom 6.0 or below: Click Lock/Unlock and select Get Lock.
    LockUnlock

  4. Choose Server URL.
    Check Browse - Checkin Dialog
    Check Browse – Checkin Dialog

Release Lock

  1. Save your current document.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  3. Zoom 7.0:


    Zoom 6.0 or below: Click
     Lock/Unlock and select Release Lock.
    LockUnlock

  4. Choose Server URL.
    Check Browse - Checkin Dialog
    Check Browse – Checkin Dialog

When editing an asset inside of Zoom, Revert allows you to revert back to the last revision checked out from the Zoom Server. This will remove any of the modifications that were applied to the asset.

Revert Changes

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  2. Zoom 7.0: Click Revert Project from the fly-out menu

     

    Zoom 6.0 or lower: Click Revert. In the drop-down, select Revert Changes.
    Revert

  3. Click OK.

When a file is changed on the Zoom Server, for example a new version is created, the file on your computer now is older than the latest version on the server and needs to be updated. Updating the files will update the file if there is a newer version or move it if it was moved on the Zoom Server.

Update Asset

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  2. Zoom 7.0: Click Sync. Sync will determine if update from or check-in to server is needed.

     

    Zoom 6.0 or lower: Click Update.
    Update

  3. Click OK.

The Task Manager allows users who have the Workflow module to accept and submit tasks assigned to them within a Workflow Job. The Task Manager can be launched directly from with the Creative App Plugin.

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.

    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom
  2. Click Task Manager.
    TaskManager
  3. Click OK.

The Show in Asset Browser button in the Creative App Plugin allows users to navigate to the asset they have open in the Creative App within Asset Browser.

Show Current Asset in Asset Browser

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

  2. Zoom 7.0: Click 

    or from any view, select a file:

    Zoom 6.0 or below: Click Show in Asset Browser.
    ShowInVAB

  3. Click OK.

The Status button shows the detailed current status of a working copy on your computer locally and on the Zoom Server. This includes information such as File Status, Size, Modification Date, etc.

View Asset Status

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.

    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom
  2. Click Status.
    Status

Reveal in Explorer button in the Creative App Plugin navigates to the working copy within Windows Explorer or the Apple Finder on your computer.

Reveal in Windows Explorer or Apple Finder

  1. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
  2. Zoom 7.0:

    or from any file that can be accessed without the cloud icon:

    Zoom 6.0 or below: Click Reveal in Explorer.
    RevealInExp

Resolve Links functionality, available in the Creative app panel can be used to replace broken/unversioned links in the main with the links in the working copy. It works on a file which was checked into Zoom Server along with all its links. Resolve links will not work properly if the links have been re-ordered. So, if there is a need to re-order the links in the main file, make sure to issue Resolve Links before re-ordering.

  1. Open a the file for which you need to Resolve Links in the appropriate Creative App.
  2. Open the Evolphin Zoom panel by navigating to Window > Extensions > Evolphin Zoom.
    Window > Extensions > Evolphin Zoom
    Window > Extensions > Evolphin Zoom

     

  3. Make sure that the linked files are also checked out in your machine.
  4. Zoom 7.0: Via the fly-out menu, Click Resolve Links.

    Zoom 6.0 or below: Click Resolve Links.
    ResoliveLinks

Resolve Links best practices:

  • Scenario – There is a PhotoShop file Main.psd. It has links to ~/Desktop/links/Link1.jpg and ~/Desktop/links/Link2.jpg. Main.psd is checked-in to Zoom along-with the links and with Convert to WC checked. In this case, Main.psd, Link1.jpg and Link2.jpg will all get checked into Zoom Server and the versioned copy of Main.psd would open up in PhotoShop. After check-in, resolve links will automatically run so that the links of Main.psd get updated to the versioned copies of Link1.jpg and Link2.jpg instead of the original link files in ~/Desktop/links. If it fails in any case, make sure to click on Resolve Links manually.
  • Resolve links would look for files in the order – third party mount points, auto-checkout mount points, working copy. This means if you want to resolve paths only from the working copy, make sure auto-checkout mount point and third party mount points do not have copies of your linked files. For high-res files, by default the links will be resolved in the order of high-res, pro-res, low-res(auto-checkout mount point, working copy).

 

For Adobe After Effects, Zoom ships with a script for automating the render and import process. The script can be installed as a menu option under the File → Scripts panel in Adobe After Effects.

Installing the Render and Import Script

  1. Find the ZmAfterEffectsRenderScript.zip file. This is located in the Evolphin Zoom install directory, under the DAM\plug-ins folder. If you aren’t sure where the you installed Evolphin Zoom, please ask an administrator
    • Windows (32-bit): C:\ Program Files\Evolphin\DAM\plug-ins
    • Windows (64-bit): C:\Program Files (x86)\Evolphin\DAM\plug-ins
    • MacOS: /Applications/Evolphin/zoom/Resources/plug-ins
  2. Unzip the file to your Adobe After Effects Scripts folder. This can be found in the location you installed Adobe After Effects, under the Support Files\Scripts folder on Windows, or /Resources/Support Files/Scripts. If you aren’t sure where this can be found, ask your administrator
    • Windows : C:\Program Files\Adobe\Adobe After Effects CC 2015\Support Files\Scripts
    • MacOS: /Applications/Adobe After Effects CC 2015/Scripts

    You should end up with evolphin Zoom – Render and Import.jsx under the Scripts folder.

  3. Launch After Effects and look for the script named evolphin Zoom – Render and Import.jsx under the File -> Scripts menu:
    AE_Render_ImportRender_import_MAC_menu

 

Running the Render and Import script

  • Make sure that the default server is set in Z-settings-> Server/WC Settings.
    Z-Settings_default_server

 

  • If mandatory metadata is enabled in the server, ensure that a default Metadata Preset saved. Click here to know how to save default Metadata Preset.
  • Before launching the script, ensure the Adobe After Effects render settings are specified in the Zoom Settings panel (launched from the desktop via the “Z” icon context menu):
    AE_Render_Settings
    “Import destination” points to the project root folder or the sub-folder under which rendered files will be saved automatically.
  • In After Effects preferences, make sure ”Allow Scripts to Write Files and Access Network” checkbox is selected. Without this option, Zoom script will be unable to communicate with the Zoom DAM service.
    AE_Render_Prefernces
  •  Set up the After Effects render queue by adding items to the render queue, along with output modules.AfterEffects_RenderQueue
  •  Next, click on the evolphin Zoom – Render and Import.jsx under the File menu to start rendering. Once rendering is finished, Zoom will trigger check-in, you will see the check-in dialog popup, and execute automatically. Once the import is finished, notifications will pop up in the system tray or Mac menu bar.
    AEP_Render_progress
  • Adobe After Effects will also pop up an alert:
    AE_Render_alert
  • During the import, if an output file does not exist, it would be ignored, and the rest of the files would be imported. Zoom will create a sub folder based on the project name.
    AE_Rendered_VAB